[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

minix FS broken ???


  I discovered a bug while trying to build new boot disks.
I create a minix filesystem in a file mounted through the loopback service:

# dd if=/dev/zero of=/tmp/image bs=1k count=1440
# mkfs.minix -n30 -i 850 /tmp/image 1440
# mount -t minix -o loop /tmp/image /mnt

but when I create files on this filesystem, its contents appears completely

# cp /bin/ls /bin/rm /mnt
# ls -l /mnt
total 14
drwxr-xr-x   2 root     root           96 May  9 23:37 
?---------   1 root     root            0 Jan  1  1970 LF???
-rwxr-xr-x   1 root     root        11784 May  9 23:37 rm

I tried to trackdown the bug with no success at all :-((
It seems to be a pb in the size of the directory structure, or something
like that.  The directory contents is not decoded the right way.

Anyone experienced such behavior ???  It seemed to work some time ago, because
I was able to create the Debian boot disks !

PS: I'm running sparclinux 2.0.33, either minix in external module or not
  (tried both), libc6 2.0.92 or 2.0.93, fileutils 3.16-5, util-linux 2.7.1-3.

 Eric Delaunay                 | "La guerre justifie l'existence des militaires.
 delaunay@lix.polytechnique.fr | En les supprimant." Henri Jeanson (1900-1970)

To UNSUBSCRIBE, email to debian-sparc-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: