[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem using arphic chinese truetype fonts

On Mon, May 15, 2000 at 09:26:52AM +0800, 50191914@uxmail.cityu.edu.hk wrote:
> 	When I tried to use the arphic chinese truetype fonts in
> application such as crxvt or netscape.The application will hang...
> and after I tried to kill the application,the X windows exit abnormally
> and I find that the xfs-xtt is killed.What's the problem?

As a general rule, when you are reporting a problem, please be more specific
and tell us the details.  In particular:

  * What platform? (i386?)  How much RAM?  How much free memory?  etc.
  * Are you using all-Debian packages?  Or did you "roll-your-own"?
  * What versions of Debian packages, esp. ttf-arphic-*, xfonts-arphic-*,
    xfs-xtt, libxfont-xtt, xlib6g, freetype2, and your Linux kernel, etc.
  * potato, woody, or Debian 2.1?
  * What were the exact commands you used to run crxvt and friends?
  * Was the xfs-xtt killed _before_ or _after_ you tried to use any of the
    arphic fonts?
  * Have you been able to use any other TrueType fonts sucessfully with

Arphic fonts work great on my Cyrix P166 system with 64MB RAM, Linux
kernel 2.2.15, and XFree86 3.3.6, running on a Debian 2.2 (potato) system.

If you have xfonts-arphic-????00?p_2.10 installed, I suggest that you
try xfonts-arphic-????00?p_2.11, which is currently sitting in "Incoming".
You may find the following files at:


 ce1d1c504eec03707be8fcc7fb80f4b1 4706 x11 optional xfonts-arphic-bsmi00lp_2.11_all.deb
 64133d9bb9d9f62c6e01a881e7124b89 4710 x11 optional xfonts-arphic-bkai00mp_2.11_all.deb
 e8a9e765fb44b1d4ea4974323e9eb4eb 4704 x11 optional xfonts-arphic-gbsn00lp_2.11_all.deb
 53219e29435081cd2356297418be7668 4710 x11 optional xfonts-arphic-gkai00mp_2.11_all.deb

Here's the changelog:

xfonts-arphic (2.11) frozen unstable; urgency=low

  * To Release Manager: As the changes are minimal, and it would
    reduce the overhead and improve the stability of the X server and
    X font server, please include it in potato.
  * Removed the number of aliases for the fonts.  There were 648 aliases
    for each single Chinese TTF font, most of them just for circumventing
    the font size glitch in Netscape 4.x.  No wonder xlsfonts was so slow.
    Mea culpa.  :-)  The number of aliases has been reduced to 88.
  * [README.Debian]: Added a note to tell the users to use -default-*
     instead of -arphic-* in Netscape 4.x for the Chinese TrueType
     fonts to be displayed properly.

 -- Anthony Fok <foka@debian.org>  Sat, 13 May 2000 02:54:17 -0600

This might help if you have, say, less than 32MB.

You may also check your /etc/X11/xfs/config and /etc/X11/XF86Config
files. I've attached the former with this message.  As for XF86Config,
make sure you have the line

    FontPath   "unix/:7100"

and all the other direct FontPaths removed or commented out, so
the fontpaths listed in in xfs/config are not repeated in XF86Config.

Please let me know if the above remedies work or not.


Anthony Fok Tung-Ling                Civil and Environmental Engineering
foka@ualberta.ca, foka@debian.org    University of Alberta, Canada
Come visit Our Lady of Victory Camp -- http://www.olvc.ab.ca/

Reply to: