[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Recent problem with security repository?

Benedikt Hallinger wrote:
> Good morning,
> at one of my boxes i run apticron. Since the last night, i am unable to use
> aptitude (also apt doesn't work) anymore.
> My sources-list contains:
> deb http://security.debian.org etch/updates main

And what else does it contain?
> This happens if i do an aptitude update:
> Hit http://security.debian.org etch/updates/main Packages
> Fetched 4B in 0s (5B/s)
> Reading package lists... Error!
> E: Dynamic MMap ran out of room
> E: Error occurred while processing libcairo-directfb2 (NewVersion1)
> E: Problem with MergeList
> /var/lib/apt/lists/security.debian.org_dists_etch_updates_main_binary-amd64_Packages
> E: The package lists or status file could not be parsed or opened.
> E: Couldn't rebuild package cache
> The errors do also occur if i run any other apt/aptitude command.

See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=337831

> Strangely, on my other box this doesn't happen. Is something corrupt on the
> machine?
> If i manually remove the package cache and do "aptitude update", the
> problem is reproducable.
> Any help is greatly appreciated.

Raise APT::Cache-Limit as the bugreport suggests
, or use fewer entries in sources.list.

Best regards,

Reply to: