[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [SECURITY] [DSA 1017-1] New Linux kernel 2.6.8 packages fix several vulnerabilities

Ralph Katz wrote:
> I had to manually install kernel-image-2.6-686, otherwise no upgrade was
> initiated.

That's unavoidable. The ABI had changes, so we needed to changes binary
package names. That's what the kernel-image-2.6-686, they provide a
correct pointer to the current image.

> If I did not subscribe to debian-security-announce, I never would have
> known that aptitude update/upgrade would /miss/ this important security
> upgrade.

It's mandatory to subscribe to debian-security-announce if you install
security updates. While most upgrades can run unattended there will always
be corner cases, that require special attention of the local admin installing
the update. A kernel update with an ABI bump is such a corner case.


Reply to: