[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cyrus21 does not work corectly with SSL

On Di, 15.02.2005, 21:53, Nicolas Ledez wrote:
> Le Tue, Feb 15, 2005 at 06:47:53PM +0100, Christian Storch a écrit :
>> I've tried your scripts for creating root and server certs.
>> Testing with s_client on two different servers I got no errors
>> but nearly the same output you've posted!
> I try to find more information for my certificate.
> With openssl verify -CApath /etc/ssl/certs/ -issuer_checks
> imap.winch.my.crt
> I have "error 29 at 0 depth lookup:subject issuer mismatch" errors.
> I think it's normaly.
> What command can I use to test certificate ?

Yes, I've the same error with working certs.
The only simple possibility I know is to check by

openssl x509 -in <certificate file> -noout -issuer -subject -startdate

perhaps '-text' for more detailed information.
But that's no check of trust relation!
One possibility to test without a client server application is
to import root cert, client cert and its key into a kind of OS
made in Redmond. ;)
If you want, you could send me your certs and key or make some
new ones and I could test it on a couple of cyrus servers.
So you could at least exclude this point of failure.



Reply to: