[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Serious problem after tetex security update

"s. keeling" <keeling@spots.ab.ca> writes:

> Incoming from Andreas Goesele:
>> I found the solution. There is a bug in the new package:
>> /usr/share/texmf/web2c does not link to /var/lib/texmf/web2c (as it
> Odd.  It worked for me (though I haven't tried any LaTeX commands):
> (0) keeling /home/keeling/.mozilla/plugins_ ls -al /usr/share/texmf/web2c /var/lib/texmf/web2c /var/lib/texmf/web2 
> ls: /var/lib/texmf/web2: No such file or directory
> lrwxrwxrwx    1 root     root           20 Nov 25 11:06 /usr/share/texmf/web2c -> /var/lib/texmf/web2c/

This link wasn't created in my case. But maybe I was wrong about the
reason. Just to test it I reinstalled the new package and this time
there was no problem.

The wrong link to the non-existing /var/lib/texmf/web2 in the package
might be irrelevant as the right link should be created by the
postinst script. (Anyway, so it seems to me.)

No idea why the link wasn't created when I first updated the
package. But as long nobody else gets the same problem I assume there
is no bug ...

Andreas Goesele

Omnis enim res, quae dando non deficit, dum habetur et non datur,
nondum habetur, quomodo habenda est.
                                      Augustinus, De doctrina christiana

Reply to: