[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]



> Hi all,
> I still have a masquerade problem, and nothing helps me to go to the right
> way.
> This is my configuration :
> A server ( with internet access on eth0, and local network access

why you don't assign an internet number on eth0 if your eth0 interfaces
is on the internet side ? is a entire class A for internal network.
I think this may be a problem if you don't have
a router/gateways with another NAT active ... and NAT over NAT
can do a regular job ? never tryed ;-)

> ( on eth1
> A workstation ( wants to access to internet
> This is what I done :
> On the workstation, I specify the gateway and the dns as
> On the server, I ran the following code :
>            iptables -t nat -A POSTROUTING -s -o eth0 -j
> When I tried my configuration, the log said to me : 'bad port from
> Anyone can help me ?

i suppose that you have already compiled the kernel
with ip forward and masquerading support
#apt-get update
#atp-get install ipmasq
#cat >/etc/ipmasq/rules/A01interfaces.rul

reboot or do /etc/init.d/ipmasq start

bye |
bye |hor

Reply to: