[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SECURITY] [DSA 2305-1] vsftpd security update

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA-2305-1                    security@debian.org
http://www.debian.org/security/                                 Nico Golde
September 19, 2011                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : vsftpd
Vulnerability  : denial of service
Problem type   : remote
Debian-specific: no
Debian bug     : 622741 629373
CVE IDs        : CVE-2011-0762 CVE-2011-2189

Two security issue have been discovered that affect vsftpd, a lightweight,
efficient FTP server written for security.


    It was discovered that Linux kernels < 2.6.35 are considerably slower in
    releasing than in the creation of network namespaces.  As a result of this
    and because vsftpd is using this feature as a security enhancement to
    provide network isolation for connections, it is possible to cause denial
    of service conditions due to excessive memory allocations by the kernel.
    This is technically no vsftpd flaw, but a kernel issue.  However, this
    feature has legitimate use cases and backporting the specific kernel patch
    is too intrusive.  Additionally, a local attacker requires the CAP_SYS_ADMIN
    capability to abuse this functionality.  Therefore, as a fix, a kernel
    version check has been added to vsftpd in order to disable this feature
    for kernels < 2.6.35.


    Maksymilian Arciemowicz discovered that vsftpd is incorrectly handling
    certain glob expressions in STAT commands.  This allows a remote authenticated
    attacker to conduct denial of service attacks (excessive CPU and process
    slot exhaustion) via crafted STAT commands.

For the oldstable distribution (lenny), this problem has been fixed in
version 2.0.7-1+lenny1.

For the stable distribution (squeeze), this problem has been fixed in
version 2.3.2-3+squeeze2.  Please note that CVE-2011-2189 does not affect
the lenny version.

For the testing distribution (wheezy), this problem will be fixed soon.

For the unstable distribution (sid), this problem has been fixed in
version 2.3.4-1.

We recommend that you upgrade your vsftpd packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
Version: GnuPG v1.4.11 (GNU/Linux)


Reply to: