[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: OpenBlas Pthread issue with R

Le vendredi 01 mai 2020 à 07:05 -0500, Dirk Eddelbuettel a écrit :
> On 1 May 2020 at 05:16, Mo Zhou wrote:
> > On Thu, Apr 30, 2020 at 11:26:23PM -0500, Dirk Eddelbuettel wrote:
> > > Switching to libopenblas0-openmp works but one needs to uninstall
> > > libopenblas0-pthread (or else fiddle with the alternatives priority).
> > 
> > Does that mean the update-alternatives mechanism is malfunctioning?
> I do not know.
> It could just be the default ranking is wrong. I did not check, and was
> interested in fiddling manually (as I find it always bites me years later...)
> Given that openblas-pthread renders R _unuseable_ and that Seb said it was a
> known issue, maybe we should ensure it ranks lower than it currently does?

I did not say that it is a known issue. I said that we had a similar
issue in the past, but that it was solved.

Also, I tried to reproduce the problem on an unstable system with
OpenBLAS/pthreads selected as the alternative, but I couldn’t. The
computation goes fine for me. So I guess the problem manifests only on
specific systems or CPUs.

I suggest that you open a bug report, providing as many details as
possible on the system where it manifests (in particular, the precise
CPU model).

Also, I don’t think we should change the alternatives priorities. The
OpenMP flavour of OpenBLAS has its own problems (in particular, because
it is compiled with GNU OpenMP, it is incompatible with applications
compiled against Intel’s OpenMP, and we cannot do anything about that).
So we should rather fix the bug that you encountered.

⢀⣴⠾⠻⢶⣦⠀  Sébastien Villemot
⣾⠁⢠⠒⠀⣿⡁  Debian Developer
⢿⡄⠘⠷⠚⠋⠀  https://sebastien.villemot.name
⠈⠳⣄⠀⠀⠀⠀  https://www.debian.org

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: