[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#960265: s390x install Debootstrap warning: Failure while configuring base packages. s390-tools depends on perl:any.

On 14.06.20 17:20, Philipp Kern wrote:
> On 11.05.20 11:53, Winfried Münch wrote:
>> package: s390-tools
>> Version: current Installer from 04.05.2020 21:14
>> http://ftp.halifax.rwth-aachen.de/debian/dists/buster/main/installer-s390x/current/images/generic/
>> When I install debian I run in this Problem (from console 4):
>> May 11 09:43:43 debootstrap: Errors were encountered while processing:
>> May 11 09:43:43 debootstrap:  s390-tools
>> May 11 09:43:44 debootstrap: dpkg: dependency problems prevent
>> configuration of s390-tools:
>> May 11 09:43:44 debootstrap:  s390-tools depends on perl:any.
>> May 11 09:43:44 debootstrap:
>> May 11 09:43:44 debootstrap: dpkg: error processing package s390-tools
>> (--configure):
>> May 11 09:43:44 debootstrap:  dependency problems - leaving unconfigured
>> Installation failed in step install base system.
> perl:any is not part of the transitive closure that debootstrap
> calculates. To me it looks like a bug in debootstrap in that it does not
> find a deb to download because it does not drop the :any - either in
> pkgdetails or before.
> This was presumably broken by 2.3.0-1 which packaged ziomon and included
> a ${perl:Depends} on the main package as well - possibly because Lintian
> alerted about the missing dependency. That was technically correct, as
> it includes binaries that require modules from perl rather than
> perl-base. And it would presumably have worked if "perl:any" had instead
> been substituted as "perl".
> It's pretty telling how late this was discovered, sort of pointing out
> that Debian s390x has no users at all if that kind of bug slips into a
> stable release. Ubuntu forked the base tooling and thus was not
> affected. To be honest, that tells me that the port should be demoted
> and not be part of the next release. Especially given the lack of
> (motivated) porters.

The good news is that with Debian stable 10.6 that was released today
the installation actually works again and I was able to conduct a
successful one from within z/VM.

Kind regards
Philipp Kern

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: