[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#555540: any news on tokyocabinet's FTBFS?

On Fri, May 14, 2010 at 09:43:27PM +0200, Pierre Habouzit wrote:
> On Tue, May 11, 2010 at 10:52:09PM +0200, Serafeim Zanikolas wrote:
> > Here's a ping for #555540, which is blocking the transition of bogofilter (for
> > quite a while now). It'd be sad to have to drop bogofilter support for
> > tokyocabinet.
> This ftbfs is random and only on s390, you're welcome to track it down,
> I've not been able to.
It seems that on consecutive runs of the test case[1] in question, it aborts
at different points each time and even succeeds in one in five runs or so.
Moreover, while the combined assert() condition fails, separate assert() calls
for each of the condition succeed while their combination still fail(!)

All in all, the whole thing sounds like a miscompilation/toolchain bug. I
tried compiling (on zelenka, b-d installed there) with -O0 and indeed the
whole test suite succeeds.

BTW, compiling with -O0 was more tricky than just exporting DEB_BUILD_OPTS;
upstream's configure script is doing something fishy with its own CFLAGS
variable (called MYCFLAGS) with the goal of redefining optimization levels
depending on configure options; you should probably fix this.

Finally, while you mentioned that the bug is in linux-2.6, I couldn't find any
indication about that on this bug report, which is still assigned to
tokyocabinet. If there is another bug on Linux that's affecting this bug, I
couldn't find it; in any case, you should probably mark this on the BTS.


1: LD_LIBRARY_PATH=.  ./tcbmttest read -df 5 casket 5

Reply to: