[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#499833: marked as done (chccwdev cannot set device offline in Lenny)

Your message dated Mon, 25 Jan 2010 05:58:04 +0100
with message-id <201001250558.05057.elendil@planet.nl>
and subject line Bug#499833: chccwdev cannot set device offline in Lenny
has caused the Debian Bug report #499833,
regarding chccwdev cannot set device offline in Lenny
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

499833: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=499833
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: s390-tools
Version: 1.6.2-1

This works just fine in Etch, but fails in Lenny.  A device cannot be taken
offline dynamically.  In my case, I have a separate dasd device for use as
a boot partition.  The device number is 0201, which Linux references as
0.0.0201.  The device node name for this device is /dev/dasdb.  The
device has a single partition, /dev/dasdb1, is formatted using the ext3
file system, and is mounted as /boot in /etc/fstab.  The device normally
uses the dasd_diag_mod driver, but in order to get zipl to work, I have
to switch to the dasd_eckd_mod driver.  The following sequence of commands
(logged in as root) is what I normally use in Etch with my custom kernel:

umount /boot
echo 0 >/sys/bus/ccw/devices/0.0.0201/online
echo 0 >/sys/bus/ccw/devices/0.0.0201/use_diag
echo 1 >/sys/bus/ccw/devices/0.0.0201/online
mount -t ext3 /dev/dasdb1 /boot
. invoke zipl (or update-initramfs, or aptitude dist-upgrade, or whatever)
umount /boot
echo 0 >/sys/bus/ccw/devices/0.0.0201/online
echo 1 >/sys/bus/ccw/devices/0.0.0201/use_diag
echo 1 >/sys/bus/ccw/devices/0.0.0201/online
mount -t ext3 /dev/dasdb1 /boot

When I do this under recent versions of Lenny, though, the device never goes
offline, as verified by

cat /sys/bus/ccw/devices/0.0.0201/online

which still shows 1 after supposedly setting the device offline.  Another
way of telling is to issue

cat /proc/dasd/devices

which still shows the device online using the original DIAG driver.

I tried using

chccwdev -d 0.0.0201

also, and it says that it did it, but in reality nothing has changed.
The device is still online.  Just for grins, I tried setting a device
offline dynamically which was using the ECKD driver, but that
doesn't work either.

Kernel is stock Lenny kernel linux-image-2.6.24-1-s390, Version 2.6.24-7.


--- End Message ---
--- Begin Message ---
I'm closing this old report as it does not seem to be a bug in s390-utils 
and from the bug log the issue looks to have been resolved.

If there still is an issue affecting current kernels, you will probably get 
much more response reporting it to the upstream kernel developers than 
with a Debian bug report.


--- End Message ---

Reply to: