[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem with new OSA in HiperSocket mode on Debian

Hello Guys,

I have something to go up automatically an interface OSA from Guest Lan Hipersocket, in Debian on System z.

I changed /etc/network/interfaces and put the IP configuration of the new interface (hsi0). It also created the file /etc/sysconfig/hardware/config-ccw-0.0.0800 with the addresses of the device and interface name.

CCWGROUP_CHANS=(0.0.0800 0.0.0801 0.0.0802)

When I give lsqeth  command, the device appears, but no device name:

Device name                     :
       card_type               : HiperSockets
       cdev0                   : 0.0.0800
       cdev1                   : 0.0.0801
       cdev2                   : 0.0.0802
       chpid                   : 00
       online                  : 0
       portname                : no portname required
       portno                  : 0
       route4                  : no
       route6                  : no
       checksumming            : sw checksumming
       state                   : DOWN
       priority_queueing       : always queue 2
       fake_ll                 : 0
       fake_broadcast          : 0
       buffer_count            : 16
       add_hhlen               : 0
       layer2                  : 0
       large_send              : no

I tried to search for something on the interface that already "up" automatically, but did not find anything significant. I wonder if anyone has solved this problem.

I know I can put a clause in the pre-up /etc/network/interfaces and a script with "echo 1> /sys/devices/qeth/0.0.0800/online", but I would like to know if there is one less way to do this craft.


Best Regards,

Fernando Gieseler
Technical Sales Specialist for System z
-  Linux and z/VM -
IBM Brasil
fone: +55-51-2131-5848
cel: +55-51-9988-8177
fax: +55-51-2131-5875
ITN: 5 759-5848
T/L: 859-5848

Reply to: