[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#499833: chccwdev cannot set device offline in Lenny

Package: s390-tools
Version: 1.6.2-1

This works just fine in Etch, but fails in Lenny.  A device cannot be taken
offline dynamically.  In my case, I have a separate dasd device for use as
a boot partition.  The device number is 0201, which Linux references as
0.0.0201.  The device node name for this device is /dev/dasdb.  The
device has a single partition, /dev/dasdb1, is formatted using the ext3
file system, and is mounted as /boot in /etc/fstab.  The device normally
uses the dasd_diag_mod driver, but in order to get zipl to work, I have
to switch to the dasd_eckd_mod driver.  The following sequence of commands
(logged in as root) is what I normally use in Etch with my custom kernel:

umount /boot
echo 0 >/sys/bus/ccw/devices/0.0.0201/online
echo 0 >/sys/bus/ccw/devices/0.0.0201/use_diag
echo 1 >/sys/bus/ccw/devices/0.0.0201/online
mount -t ext3 /dev/dasdb1 /boot
. invoke zipl (or update-initramfs, or aptitude dist-upgrade, or whatever)
umount /boot
echo 0 >/sys/bus/ccw/devices/0.0.0201/online
echo 1 >/sys/bus/ccw/devices/0.0.0201/use_diag
echo 1 >/sys/bus/ccw/devices/0.0.0201/online
mount -t ext3 /dev/dasdb1 /boot

When I do this under recent versions of Lenny, though, the device never goes
offline, as verified by

cat /sys/bus/ccw/devices/0.0.0201/online

which still shows 1 after supposedly setting the device offline.  Another
way of telling is to issue

cat /proc/dasd/devices

which still shows the device online using the original DIAG driver.

I tried using

chccwdev -d 0.0.0201

also, and it says that it did it, but in reality nothing has changed.
The device is still online.  Just for grins, I tried setting a device
offline dynamically which was using the ECKD driver, but that
doesn't work either.

Kernel is stock Lenny kernel linux-image-2.6.24-1-s390, Version 2.6.24-7.


Reply to: