[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Successful 2.6 based installation on s/390 (hercules) - some issues



(This mail is a combination of installation-report and status overview for 
the S/390 list.)

Mostly thanks to the efforts of Bastian Blank, S/390 has now made the 
switch from 2.4 to 2.6 in the installer. The installer now also uses 
partman instead of partitioner and partconf.

Both network device and DASD detection had to be made sysfs-aware. 
Together with the switch to partman, that means there have been some 
major changes. Additional testing is very welcome.

I've done two test installs using the Hercules emulator. The results are 
below.

Note: until 2.6.16 kernel packages have migrated to unstable, 
installations of testing will fail to reboot. Installations of unstable 
should work (barring any "normal" breakages in unstable).

* Network configuration (CTC)
Works fine.
Wishlist:
- Maybe we should remove the selected read device from the list when
  asking for the write device
- Maybe we could suggest default values (first available device for read;
  the one following the selected read device for write)

* DASD configuration
During the first install this failed because the DASD modules were not 
loaded. Modprobing them initially did not work because depmod had not 
been run after loading the kernel module udeb.
This was solved (worked around rather) by adding the dasd-modules udeb to 
the initrd so that initial udev runs will load them. The real solution 
would be to run depmod and rerun udev as part of dasd detection.

Issue:
- After selecting a dasd device there is no change of the status on the
  screen which makes it look as if no device has been selected yet.
  This is only a presentation bug as the selection in fact was done
  correctly.

* Partitioning - general
The old udebs used for partitioning (partitioner and partconf) are still 
in the archives and thus have to be skipped manually. Partitioner will 
probably fail; after you get back to the menu, select "Partition disks" 
instead. This is a temporary problem that will be fixed as soon as the 
udebs are removed from the archive.

* Partitioning - partman-auto
Don't use guided partitioning! Instead select "Manually edit partition 
table" in the first partman screen.
- There are no recipes for S/390 which makes partman-auto use msdos
  disklabel and try to create a logical partition for swap. This fails
  miserably.
- As guided partitioning currently only supports using one device, it's
  not much use for S/390 anyway as most installations tend to use
  multiple DASDs.
For the last reason, we'll probably just disable partman-auto for S/390 
for now.

* Partitioning - manual partitioning
Select the "s390" disklabel when using Hercules when creating a new 
partition table. I understand that msdos or gpt can be used in some 
cases.

Issue:
- When a new partition is created, it's name is shown strangely:
  LINUX.V^G^G^G^G^G^G.PART0001.NATI
  After committing the changes and restarting partman, it looks more
  normal though:
  LINUX.V0X0121.PART0001.NATIVE
  (Not sure where the 0121 comes from; the DASD I created the partition
  on was 0.0.0122!)

* Base installation - kernel selection
This is an existing issue, but worth mentioning anyway.
Selection of the default kernel could be improved for S/390. Current 
selection uses the full kernel version (e.g. 2.6.16-2-s390) used in the 
installer. This means that:
- if that kernel is not available, the fallback is not optimal; for
  example, if I install testing, the 2.6.15-1-s390x kernel will be
  selected by default (while hercules does not support s390x);
- the installer will not install one of the meta packages which means that
  the user will not get automatic security updates if they have ABI
  changes.

One thing to be aware of is that a new hardware configuration mechanism 
has been added for 2.6 kernels using the sysconfig-hardware package. The 
installer may (e.g. for CTC netdevices) create config files in directory:
/etc/sysconfig/hardware/.

Cheers,
FJP

Attachment: pgpedjIo5frGL.pgp
Description: PGP signature


Reply to: