[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

NFS mount problems

Does anyone have a clue as to what the problem is with NFSv3 in the
installation system?  Is this still a problem with more recent kernels?

----- Forwarded message from "Peter J Farley III <pjfarley3@yahoo.com>" <pjfarley3@yahoo.com> -----

Date: Sun, 16 Feb 2003 20:18:23 -0000
From: "Peter J Farley III <pjfarley3@yahoo.com>" <pjfarley3@yahoo.com>
To: hercules-390@yahoogroups.com
Subject: [hercules-390] Re: Can't nfs mount from Debian-390 bootstrap system

--- In hercules-390@yahoogroups.com, Matt Zimmerman <mdz@c...> wrote:
> Yes.  I do not know what the problem is; you might try
> debian-s390 at lists.debian.org

Thanks a lot, Matt.  I went over there and found a post from Gerhard
Tonn from October 2002, and he pointed a similar problem over on the
Marist linux390 list (see his post from the October 2002 Marist
archive at this url (watch wrapping!): 

>A similar problem was discussed on the Marist list
>Could you give that a try.

At the linux390 link, I found this advice from Stefan Gybas:

>This might be a problem with the NFS version. Could you open a 
>shell from dbootstrap and try to manually mount the NFS filesystem 
>mount newton:/cdrom/cdrom0/dists/woody/main/disks-s390/current \
>      /instmnt -o nolock,nfsvers=2
>and then try to continue the installation? Please tell me if this
>works for you. We might have to disable NFSv3 for the installation 
>system in this case.

Well, I brought up the installation bootstrap system as far as
telnetting in to start the configuration, then telentted into a 
second session.  The "mount" suggested by Stefan worked!

However, that syntax results in an RW mount to an RO source, so I
tried this syntax instead:

mount -o ro,nolock,nfsvers=2 server:/mnt/cdrom /instmnt

And this also worked fine, I could read files from the DVD mounted 
at the RH base system's /mnt/cdrom device (which is really a DVD ROM
drive) from the 2nd telnet into the installation bootstrap system.

Then I tried it with the configuration dialogs, and this response to
the NFS option's request for the nfs mount point also worked:

-o ro,nolock,nfsvers=2 server:/mnt/cdrom

So, I am off and running with an install from the DVD of Debian-390. 
I will report back when I'm done with the install and let everyone
know how it works.  I am wary of using nolock, though I suppose it
won't hurt in my single-system setup.  I will also try it without 
the nolock option and see if that makes a difference.

When I'm done with this install (and a few testing upgrades I need 
to make to work on a project I'm on), I'll post a mini-HOWTO to the
files section here for those who want to try it.

More as it happens.


------------------------ Yahoo! Groups Sponsor ---------------------~-->
Get 128 Bit SSL Encryption!

Community email addresses:
  Post message: hercules-390@yahoogroups.com
  Subscribe:    hercules-390-subscribe@yahoogroups.com
  Unsubscribe:  hercules-390-unsubscribe@yahoogroups.com
  List owner:   hercules-390-owner@yahoogroups.com

Files and archives at:

Get the latest version of Hercules from:

Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/ 

----- End forwarded message -----

 - mdz

Reply to: