[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian GNU/Linux 5.0.2 - умеет ставить разные версии Debian ?



Title: Re: Debian GNU/Linux 5.0.2 - умеет ставить разные версии Debian ?

* Nicholas <spam@networkgate.us> [Tue, 30 Jun 2009 09:52:17 -0400]:

 
> Еще близкий по теме вопрос:
>
> Если существует пакет (gnumeric) версия которого из Snapshots гораздо
> для меня удобнее, чем версии из Etch и Lenny. Как в этой ситуации ее
> лучше ставить ?
>
> Сейчас используются смешанный вариант и много проблем с зависимостями -
> создается впечатление, что разработчики нарочно уменьшают диапазон
> версий библиотек с которыми работает программа, что бы не тестировать с
> каждой.
> В этой ситуации очень сложно инсталировать новые пакеты.
>
> Возможно есть репозитарии с изменной, более либеральной политикой,
> специально для Snapshots, где собранно _большое_количество_ более-менее
> стабильных версий из бывших тестингов ?
>
> Ведь это сложно подставлять свою дату для каждого пакета в
> deb http://snapshot.debian.net/archive/YYYY/MM/DD/debian unstable main
> contrib non-free
>
>

Хм, Николас, долго въезжал в смысл сей простыни...
1) Про диапазон версий слышу первый раз, обычно для корректной работы
приложения нужно, чтобы библиотека соотвествовала минимальной версии, если
конечно мы говорим не о  такой древней версии, которая интересна только археологам ;)))
 
2) Не знаю, что за сервис предоставляет snapshot.debian.net, но последний слепок
там делался, если судитьпо тому же пакету "gnumeric" ( v1.6.3), где-то эдак год назад во времена 
расцвета дистрибутива "etch".  На официальном сайте Gnumeric.org сейчас  стабильной версией
этого офисного приложения является v1.8.4, а не стабильная v1.9.9 . Поэтому думаю, что вопрос
отпадает сам собой ;)))
 
--
С уважением Андрей Ржавсков,
rjaan@rambler.ru


Reply to: