[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS:ruby-parallel

Hi Matanya.

On Tue, Feb 25, 2014 at 02:04:10PM +0200, matanya wrote:
> Hello,
> I have uploaded my first ruby package ruby-parallel to git:
> http://anonscm.debian.org/gitweb/?p=pkg-ruby-extras/ruby-parallel.git;a=summary
> ruby-parallel (0.9.2-1) unstable; urgency=low
> Could any dd please have a look and mentor?

Here are a few comments:

- Standards-Version should be 3.9.5 (that is the latest version of the
  policy atm).
- the short description should not be a verb, but a noun. Something that 
  can be used instead of the dots in:
    ruby-parallel is a ...
- the long description should use full sentences, and you should remove the > symbols
  If needed, ask on debian-l10n-english for help with writing a good
  description for this package.

debian/copyright is ok.

The upstream source code contains a spec/ directory that is not included
in the gem. The gem does not contain the README.md too.
- please ask upstream to include them in the gem
- if upstream does not include it, use the tarball from GitHub
  as the source instead of the gem.
  There is some info here on that topic:



Attachment: signature.asc
Description: Digital signature

Reply to: