[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RubyGems package

On Mon, 2005-01-31 at 12:48 +0900, Daigo Moriwaki wrote:
> deb-src http://www.sgtpepper.net/hyspro/deb ./

Some glitches I found:

* libgems-ruby fails while building it on a clean (pbuilder)

install rubygems_version.rb /usr/lib/ruby/1.8/rubygems
<--- lib/rubygems
<--- lib

As of RubyGems 0.8.0, library stubs are no longer needed.
Searching $LOAD_PATH for stubs to optionally delete (may take a
No library stubs found.

./lib/rubygems/loadpath_manager.rb:5:in `require__': No such file to
load -- zlib (LoadError)
        from ./lib/rubygems/loadpath_manager.rb:5:in `require'
        from ./lib/rubygems/package.rb:9
        from ./lib/rubygems/loadpath_manager.rb:5:in `require__'
        from ./lib/rubygems/loadpath_manager.rb:5:in `require'
        from ./lib/rubygems/builder.rb:1
        from ./lib/rubygems/loadpath_manager.rb:5:in `require__'
        from ./lib/rubygems/loadpath_manager.rb:5:in `require'
        from ./lib/rubygems.rb:66:in `manage_gems'
         ... 8 levels...
        from setup.rb:710:in `__send__'
        from setup.rb:710:in `invoke'
        from setup.rb:674:in `invoke'
        from setup.rb:1352
make: *** [build] Error 1
pbuilder: Failed autobuilding of package
 -> Aborting with an error

(need of libzlib-ruby as a build dependency?)

* Depending on ruby on debian/control indicates:

Build-Depends: debhelper (>= 4.0.0), ruby (>= 1.8), ruby (<< 1.9),
ruby1.8, libruby1.8, libyaml-ruby1.8

Are you pretty sure of that?

* Since libgems-ruby will provide atm libgems-ruby1.8, this last one
should be an indep-arch package (both are architecture dependant).

* Personal suggestion: Since there is not previous package on the
archive, why list other versions on debian/changelog?

* While writing this mail, somebody at #d-ruby asked for help installing
a gem, so I forwarded him/her to your package, and this is what he/she

<britt_radiofree> damog, gem install rails fails complaining about not
having rubygems src
<britt_radiofree> i don't see it in the repository though
<britt_radiofree> /usr/local/lib/site_ruby/1.8/rubygems.rb:131:in
`activate':  (Gem::LoadError)
<britt_radiofree> Could not find RubyGem sources (> 0.0.0)

* Upstream latest release is not 0.8.3, why not package 0.8.4?

Only that atm.

David Moreno Garza <damog@damog.net> | http://www.damog.net/
 Plant a tree sometime. 
 GPG: C671257D - 6EF6 C284 C95D 78F6 0B78 FFD3 981C 5FD7 C671 257D

Reply to: