[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#785198: transition: GStreamer 0.10 removal



Package: release.debian.org
Severity: normal
User: release.debian.org@packages.debian.org
Usertags: transition

Hi,

see rationale in this mailing list thread:
https://lists.debian.org/debian-devel/2015/05/msg00335.html

It was suggested in that thread to also set up a transition tracker for
this. The main package involved here would be libgstreamer0.10-0, which
should go away and has libgstreamer1.0-0 as replacement already.

The qt-gstreamer transition (#760003) already clears part of the
remaining GStreamer 0.10 dependencies. Additionally there are further
GStreamer 0.10 bindings:

python-gst0.10 is replaced by python-gst1.0 / python3-gst1.0

libgstreamer0.9-cil is replaced by libgstreamer1.0-cil
  (which is not yet uploaded, upstream release exists)

libgstreamermm-0.10-2 would be replaced by libgstreamermm-1.0-XXX
  (which is also not yet uploaded, upstream release exists)

libgstreamer-perl, haskell-gstreamer
  I'm not aware what the plans there are, the latter also has nothing
  depending on it.

Sebastian

Attachment: signature.asc
Description: This is a digitally signed message part


Reply to: