[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#783404: jessie-pu: package perl/5.20.2-3+deb8u1



On Sun, 2015-05-03 at 16:05 +0100, Dominic Hargreaves wrote:
[...]
> This doesn't seem to have built:
> 
> https://buildd.debian.org/status/package.php?p=perl&suite=jessie
> 
> This appear to be related to the change in 5.20.2-2 to make perl depend on
> a matching perl-base (see #779455). However this doesn't seem to break
> builds in sid[1], which I don't quite understand; maybe a timing issue
> over when the the new perl-modules package enters the archive compared
> with the p-u suites?
> 
> I'm not quite sure what the correct fix is here; maybe someone more
> familiar with this part of the infrastructure can suggest something?

While people ponder what the difference between the sid and p-u setups
is that causes this (or, more precisely, doesn't cause it in sid), as an
experiment we've told wanna-build to ignore the installability checker
issue on amd64 (as the versioned dependency from perl to perl-modules is
otherwise met in Jessie) and try building the package anyway. If that
works then we can try other architectures as well.

It's not an ideal long-term solution but will hopefully at least unblock
the logjam.

Regards

Adam


Reply to: