[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Please do not unblock gnome-meta just yet

Andreas Barth <aba@ayous.org> writes:
> * Julien Cristau (jcristau@debian.org) [120925 18:52]:

>> The TC decision didn't say anything about the gnome metapackage AFAICT.

> The resolution said:
> |   [...] users who have
> |   gnome or gnome-core installed but have removed or never installed
> |   network-manager will have network-manager installed during an upgrade
> |   from squeeze.

> |   The Technical Committee believes that this will cause undesireable
> |   behavior for upgrades from squeeze

> So I think while not explicitly spelling out that there should be no
> depends from gnome to n-m, adding one is against the spirit of the
> resolution.

It's a hole in my wording, which I apologize for.  I'm not sure that we
specifically discussed this case.  I had been assuming that the gnome
metapackage would pose the same issue, but I don't think I ever said that

I agree with Julien that there's no reason for the release-team to hold
off on unblocking the current package, since it doesn't make matters any
worse.  But I also agree with Ian that I don't think this is what we
intended and we probably need to talk about it again.

Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>

Reply to: