[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#683730: unblock: cups/1.5.3-2+wheezy0



Hi Julien,

I'm swapping the order of your comments for more clarity.

Le samedi, 15 septembre 2012 20.57:52, Julien Cristau a écrit :
> > === modified file 'debian/cups.install'
> > --- old/debian/cups.install	2012-05-23 10:47:58 +0000
> > +++ new/debian/cups.install	2012-08-03 10:09:05 +0000
> > @@ -50,4 +50,3 @@
> > 
> >  usr/share/man/man8/cupsfilter.8.gz
> >  #usr/share/man/*/man8/cupsfilter.8.gz
> >  ../presubj usr/share/bug/cups/
> > 
> > -../local/blacklist-cups-usblp.conf etc/modprobe.d
> > 
> > === added file 'debian/cups.maintscript'
> > --- old/debian/cups.maintscript	1970-01-01 00:00:00 +0000
> > +++ new/debian/cups.maintscript	2012-08-03 10:09:05 +0000
> > @@ -0,0 +1,1 @@
> > +rm_conffile /etc/modprobe.d/blacklist-cups-usblp.conf 1.5.3-2~
> 
> How does that work?

dh_installdeb allows one to use the .maintscript file to provide dpkg-
maintscript-helper commands. According to man dpkg-maintscript-helper, the 
version should indeed be 1.5.3-2+wheezy0~ as the "last one in which the 
conffile is".

The blacklist file is not installed anymore by the first change, un-declared 
as conffile by the second.

Le samedi, 15 septembre 2012 20.57:52, Julien Cristau a écrit :
> On Fri, Aug  3, 2012 at 12:58:06 +0200, Didier Raboud wrote:
> > === modified file 'debian/control'
> > --- old/debian/control	2012-08-02 16:35:09 +0000
> > +++ new/debian/control	2012-08-03 10:09:05 +0000
> > @@ -152,7 +152,7 @@
> > 
> >  Priority: optional
> >  Section: net
> >  Architecture: any
> > 
> > -Pre-Depends: dpkg (>= 1.15.7.2)
> > +Pre-Depends: ${misc:Pre-Depends}
> 
> Why this change?

dh_installdeb provides the correct misc:Pre-Depends substvar, this change 
makes the versioning more robust and binNMU-safe in case of need.

I will prepare a new cups update with the above changes and #683754.

Cheers,

OdyX

Attachment: signature.asc
Description: This is a digitally signed message part.


Reply to: