[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#685284: unblock: first bunch of packages switching to xz



Package: release.debian.org
Usertags: xz-for-wheezy

Please unblock these uploads of packages switching to xz compression.
They should have no source changes besides a new changelog entry:

unblock empathy/3.4.2.3-1+build1
unblock eog/3.4.2-1+build1
unblock epiphany-browser/3.4.2-1+build1
unblock evince/3.4.0-2+build1
unblock gconf/3.2.5-1+build1
unblock gnome-terminal/3.4.1.1-1+build1
unblock gnome-user-docs/3.4.2-1+build1
unblock libgweather/3.4.1-1+build1
unblock nautilus/3.4.2-1+build1

And these packages having trivial changes to switch to xz compression
(debdiff attached):

unblock app-install-data/2012.06.16.1
unblock gnome-packagekit/3.4.2-2
unblock oxygencursors/0.0.2012-06-kde4.8-2.1
unblock xkeyboard-config/2.5.1-2

Please also unblock pkg-kde-tools.  It changes the default compression
for most KDE package to xz.

unblock pkg-kde-tools/0.15.2

Ansgar

diff -Nru app-install-data-2012.06.16/debian/changelog app-install-data-2012.06.16.1/debian/changelog
--- app-install-data-2012.06.16/debian/changelog	2012-06-16 21:06:39.000000000 +0200
+++ app-install-data-2012.06.16.1/debian/changelog	2012-08-06 15:43:28.000000000 +0200
@@ -1,3 +1,10 @@
+app-install-data (2012.06.16.1) unstable; urgency=low
+
+  [ Ansgar Burchardt ]
+  * debian/rules: Use xz compression for binary packages (Closes: #683830)
+
+ -- Julian Andres Klode <jak@debian.org>  Mon, 06 Aug 2012 15:43:23 +0200
+
 app-install-data (2012.06.16) unstable; urgency=low
 
   * New snapshot
diff -Nru app-install-data-2012.06.16/debian/rules app-install-data-2012.06.16.1/debian/rules
--- app-install-data-2012.06.16/debian/rules	2012-06-16 21:06:39.000000000 +0200
+++ app-install-data-2012.06.16.1/debian/rules	2012-08-06 15:43:28.000000000 +0200
@@ -23,7 +23,7 @@
 	dh_installdeb
 	dh_gencontrol
 	dh_md5sums
-	dh_builddeb
+	dh_builddeb -- -Zxz
 
 # Build architecture-dependent files here.
 binary-arch: build install
diff -Nru gnome-packagekit-3.4.2/debian/changelog gnome-packagekit-3.4.2/debian/changelog
--- gnome-packagekit-3.4.2/debian/changelog	2012-05-15 20:23:34.000000000 +0200
+++ gnome-packagekit-3.4.2/debian/changelog	2012-08-05 16:56:51.000000000 +0200
@@ -1,3 +1,9 @@
+gnome-packagekit (3.4.2-2) unstable; urgency=low
+
+  * debian/rules: Use xz compression for binary packages (Closes: #683842)
+
+ -- Matthias Klumpp <matthias@tenstral.net>  Sat, 04 Aug 2012 21:46:48 +0200
+
 gnome-packagekit (3.4.2-1) unstable; urgency=low
 
   * New upstream bugfix release: 3.4.2
diff -Nru gnome-packagekit-3.4.2/debian/rules gnome-packagekit-3.4.2/debian/rules
--- gnome-packagekit-3.4.2/debian/rules	2012-05-15 20:23:34.000000000 +0200
+++ gnome-packagekit-3.4.2/debian/rules	2012-08-05 16:56:51.000000000 +0200
@@ -23,3 +23,6 @@
 
 override_dh_install:
 	dh_install --list-missing
+
+override_dh_builddeb:
+	dh_builddeb -- -Zxz
diff -u oxygencursors-0.0.2012-06-kde4.8/debian/changelog oxygencursors-0.0.2012-06-kde4.8/debian/changelog
--- oxygencursors-0.0.2012-06-kde4.8/debian/changelog
+++ oxygencursors-0.0.2012-06-kde4.8/debian/changelog
@@ -1,3 +1,10 @@
+oxygencursors (0.0.2012-06-kde4.8-2.1) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * debian/rules: Use xz compression for binary packages. (Closes: #683910)
+
+ -- Ansgar Burchardt <ansgar@debian.org>  Sun, 05 Aug 2012 12:24:25 +0200
+
 oxygencursors (0.0.2012-06-kde4.8-2) unstable; urgency=low
 
   * Add myself to Uploaders.
diff -u oxygencursors-0.0.2012-06-kde4.8/debian/rules oxygencursors-0.0.2012-06-kde4.8/debian/rules
--- oxygencursors-0.0.2012-06-kde4.8/debian/rules
+++ oxygencursors-0.0.2012-06-kde4.8/debian/rules
@@ -65,7 +65,7 @@
 	dh_installdeb
 	dh_gencontrol
 	dh_md5sums
-	dh_builddeb
+	dh_builddeb -- -Zxz
 
 binary: binary-indep binary-arch
 .PHONY: clean binary-indep binary-arch binary install 
diff -u xkeyboard-config-2.5.1/debian/changelog xkeyboard-config-2.5.1/debian/changelog
--- xkeyboard-config-2.5.1/debian/changelog
+++ xkeyboard-config-2.5.1/debian/changelog
@@ -1,3 +1,10 @@
+xkeyboard-config (2.5.1-2) unstable; urgency=low
+
+  [ Ansgar Burchardt ]
+  * Use xz compression for binary packages (Closes: #683891).
+
+ -- Cyril Brulebois <kibi@debian.org>  Sun, 05 Aug 2012 11:54:19 +0200
+
 xkeyboard-config (2.5.1-1) unstable; urgency=low
 
   * New upstream release:
diff -u xkeyboard-config-2.5.1/debian/rules xkeyboard-config-2.5.1/debian/rules
--- xkeyboard-config-2.5.1/debian/rules
+++ xkeyboard-config-2.5.1/debian/rules
@@ -34,4 +34,7 @@
 	touch rules/base.o_k.part
 
+override_dh_builddeb:
+	dh_builddeb -- -Zxz
+
 %:
 	dh $@ --with quilt,autoreconf --builddirectory=build/
diff -Nru pkg-kde-tools-0.15.1/bugreport.cgi?msg=15;filename=0001-debian-qt-kde.mk-Use-xz-compression-by-default.-Clos.patch;att=1;bug=657243 pkg-kde-tools-0.15.2/bugreport.cgi?msg=15;filename=0001-debian-qt-kde.mk-Use-xz-compression-by-default.-Clos.patch;att=1;bug=657243
--- pkg-kde-tools-0.15.1/bugreport.cgi?msg=15;filename=0001-debian-qt-kde.mk-Use-xz-compression-by-default.-Clos.patch;att=1;bug=657243	1970-01-01 01:00:00.000000000 +0100
+++ pkg-kde-tools-0.15.2/bugreport.cgi?msg=15;filename=0001-debian-qt-kde.mk-Use-xz-compression-by-default.-Clos.patch;att=1;bug=657243	2012-08-05 23:48:11.000000000 +0200
@@ -0,0 +1,27 @@
+From 44bde31a8807b3acbe53c78d4ba3ad07d8a2e235 Mon Sep 17 00:00:00 2001
+From: Ansgar Burchardt <ansgar@debian.org>
+Date: Sat, 4 Aug 2012 13:39:47 +0200
+Subject: [PATCH] debian-qt-kde.mk: Use xz compression by default. (Closes:
+ #657243)
+
+---
+ qt-kde-team/2/debian-qt-kde.mk |    3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/qt-kde-team/2/debian-qt-kde.mk b/qt-kde-team/2/debian-qt-kde.mk
+index d4feac9..d976b62 100644
+--- a/qt-kde-team/2/debian-qt-kde.mk
++++ b/qt-kde-team/2/debian-qt-kde.mk
+@@ -27,6 +27,9 @@ include $(dqk_dir)list-missing.mk
+ # KDE packages are parallel safe. Add --parallel to dh_auto_% commands
+ $(call set_command_options,dh_auto_%, += --parallel)
+ 
++# Use xz compression by default
++$(call set_command_options,dh_builddeb, += -u-Zxz)
++
+ # Link with --as-needed by default
+ # (subject to be moved to kde dh addon/debhelper buildsystem)
+ dqk_link_with_as_needed ?= yes
+-- 
+1.7.10.4
+
diff -Nru pkg-kde-tools-0.15.1/debian/changelog pkg-kde-tools-0.15.2/debian/changelog
--- pkg-kde-tools-0.15.1/debian/changelog	2012-06-30 12:56:46.000000000 +0200
+++ pkg-kde-tools-0.15.2/debian/changelog	2012-08-06 00:58:45.000000000 +0200
@@ -1,3 +1,10 @@
+pkg-kde-tools (0.15.2) unstable; urgency=low
+
+  * Enable xz compression for Debian Qt/KDE team packages by default.
+    (Closes: #657243) Thanks to Ansgar Burchardt for the patch.
+
+ -- Modestas Vainius <modax@debian.org>  Mon, 06 Aug 2012 01:58:43 +0300
+
 pkg-kde-tools (0.15.1) unstable; urgency=low
 
   * Team upload.
diff -Nru pkg-kde-tools-0.15.1/qt-kde-team/2/debian-qt-kde.mk pkg-kde-tools-0.15.2/qt-kde-team/2/debian-qt-kde.mk
--- pkg-kde-tools-0.15.1/qt-kde-team/2/debian-qt-kde.mk	2011-12-26 12:11:13.000000000 +0100
+++ pkg-kde-tools-0.15.2/qt-kde-team/2/debian-qt-kde.mk	2012-08-05 23:49:23.000000000 +0200
@@ -27,6 +27,9 @@
 # KDE packages are parallel safe. Add --parallel to dh_auto_% commands
 $(call set_command_options,dh_auto_%, += --parallel)
 
+# Use xz compression by default
+$(call set_command_options,dh_builddeb, += -u-Zxz)
+
 # Link with --as-needed by default
 # (subject to be moved to kde dh addon/debhelper buildsystem)
 dqk_link_with_as_needed ?= yes

Reply to: