[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#678172: zlib1g: binNMU broke multi-arch installability

2012/6/19 Mark Brown <broonie@debian.org>:
> On Tue, Jun 19, 2012 at 08:13:06PM +0200, Nicolas Le Cam wrote:
>> Recent binNMU of zlib1g on amd64 made it impossible to co-install it in a
>> multi-arch environment.
> What makes you say this, and why are you filing a bug on the package?
> Please provide a description of whatever problem you think you are
> seeing and contact the release team (who are responsible for binnmus).

Hi Mark,

This is what I'm seeing when I try to upgrade zlib1g
$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 zlib1g : Breaks: zlib1g:i386 (!= 1:1.2.7.dfsg-11+b1) but
1:1.2.7.dfsg-11 is installed
 zlib1g:i386 : Breaks: zlib1g (!= 1:1.2.7.dfsg-11) but
1:1.2.7.dfsg-11+b1 is installed
 zlib1g-dev : Depends: zlib1g (= 1:1.2.7.dfsg-11) but
1:1.2.7.dfsg-11+b1 is installed
E: Unmet dependencies. Try using -f.

$ sudo dpkg --install
(Reading database ... 158200 files and directories currently installed.)
Preparing to replace zlib1g:amd64 1:1.2.7.dfsg-11+b1 (using
.../zlib1g_1%3a1.2.7.dfsg-11+b1_amd64.deb) ...
Unpacking replacement zlib1g:amd64 ...
dpkg: error processing zlib1g:amd64 (--install):
 package zlib1g:amd64 1:1.2.7.dfsg-11+b1 cannot be configured because
zlib1g:i386 is at a different version (1:1.2.7.dfsg-11)
Errors were encountered while processing:

I'm filing a bug on the package because it was done the same way for
similar problem on other packages, see #676914, #676918 or #676686 for

Thanks for your feedback

Nicolas Le Cam

Reply to: