[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#629329: pu: package sphinx/0.6.6-3+squeeze1

On Sun, 2011-06-05 at 18:48 +0200, Jakub Wilk wrote:
> I'd like to upload new version of Sphinx into s-p-u, which fixes 
> compatibility with jQuery >= 1.4. (Upstream ships a copy of jQuery 
> 1.2.6, but in Debian we use the packaged one, which is 1.4.2 in 
> squeeze.)

I'm guessing there's no easy way to have the newer jQuery support both
versions of the syntax?  (Hey, it can't hurt to ask...)

> There are 55 documentation packages in squeeze affected by this bug.  
> Unfortunately, the sole upload of Sphinx won't automatically fix them,
> as they ship copies of broken javascript code. :(

As I understand it, most of the affected packages are arch:all, so we
can't simply fix the issues via a mass binNMU.  I don't suppose you
fancy no-change-NMUing 55 packages? ;-)

> Debdiff contains also some minor documentation improvements, which were 
> committed to our svn before the Squeeze release. Of course, I can undo 
> them if you don't think they are suitable for a stable update.

They look okay, particularly as the documentation doesn't appear to be
translated (at least in the stable package); thanks.



Reply to: