[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#629477: transition: gnustep-base, gnustep-gui, libobjc

Julien Cristau wrote:
> On Tue, Jun  7, 2011 at 21:44:15 +0300, Yavor Doganov wrote:
> > 1) The modified gnustep-make package will have no trouble migrating to
> >    testing (before the transition even commences), so it would make
> >    GNUstep development in wheezy broken, just like it is now in sid.
> > 
> Broken how?

Packages end up linking with libobjc3, while -base and -gui are linked
with libobjc2.

> > 2) Building the GNUstep packages with the non-default compiler on ia64
> >    and sparc is, strictly speaking, a policy violation.
> > 
> What part of policy?

None; it appears I am making a mistake.  I was pretty sure that there
was something like "Packages should be built with the default
compiler", but it seems I was wrong.

Reply to: