[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#629477: transition: gnustep-base, gnustep-gui, libobjc

On 06/07/2011 01:33 AM, Yavor Doganov wrote:
> Matthias Klose wrote:
>> On 06/07/2011 01:03 AM, Yavor Doganov wrote:
>>> We would like to carry out a GNUstep transition
>>> (libgnustep-base1.20->1.22; libgnustep-gui0.18->0.20) *and*
>>> libobjc2->3, ideally coinciding with the migration of gcc-defaults to
>>> testing (or even better, before that).
>> please make sure that you either use gobjc-4.6 explicitly, or that
>> you allow differing defaults depending on the platform.
> gnustep-base/1.22.0-1 currently build-depends on gobjc (>= 4:4.6).  My
> plan was to change it to "gobjc (>= 4:4.6) [!ia64 !sparc], gobjc-4.6".
> Is that good enough?

no, for that case, you need to use gcc-4.6 as the driver. If you want to do
this, maybe make the change in gnustep-make and let the gnustep-make package
depend on gcc-4.6.

Reply to: