[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#608561: pu: package pytris/0.98+lenny1

On Sat, 2011-01-01 at 16:18 +0200, Stefano Rivera wrote:
> pytris in stable doesn't run. It imports a stdlib library that was
> renamed in Python 2.5, which is the default Python in lenny.

Not so much renamed, as removed after having been deprecated for some
time; the Python 2.4 documentation for whrandom says:

"Note: This module was an implementation detail of the random module in
releases of Python prior to 2.1. It is no longer used. Please do not use
this module directly; use random instead."

> There has been a fix in testing and unstable for the last six months.
> Is this upload acceptable for s-p-u?

The changelog should probably be updated in light of the above - the
change isn't to support Python 2.6 (which wouldn't be hugely relevant in
lenny), but rather Python >= 2.5.

Other than that, please go ahead.



Reply to: