[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#601977: cyrus-sasl2-heimdal-dbg: file conflict during upgrade from lenny



On Sun, Oct 31, 2010 at 04:11:07PM -0400, Roberto C. Sánchez wrote:
> > 
> I'd be interested to know if anyone has a recommendation on how to
> handle this.  The two packages in question are -dbg packages that are
> created by dh_strip, excerpted from debian/rules below:
> 
> dh_strip -s -psasl2-bin -plibsasl2-2 -plibsasl2-modules -plibsasl2-modules-ldap -plibsasl2-modules-otp -plibsasl2-modules-sql -plibsasl2-modules-gssapi-mit -plibsasl2-dev -Nlibsasl2-modules-gssapi-heimdal --dbg-package=cyrus-sasl2-dbg
> dh_strip -s -plibsasl2-modules-gssapi-heimdal -Nsasl2-bin -Nlibsasl2-2 -Nlibsasl2-modules -Nlibsasl2-modules-ldap -Nlibsasl2-modules-otp -Nlibsasl2-modules-sql -Nlibsasl2-modules-gssapi-mit -Nlibsasl2-dev --dbg-package=cyrus-sasl2-heimdal-dbg
> 
> Both packages need to be able to be installed together, so my question
> centers around whehter it is OK to put a diversion in place so that
> cyrus-sasl2-heimdal-dbg diverts the file.  What does everyone think?
> 
So, it appears that there are some other possibilities, thanks to a
posting by Luca Capello [0].  The first possibility is trivial, but is
not as "correct."  The second is more "correct" but a larger diff.
Given that this must go into Lenny, what opinion or preference does the
release team have on the matter?

Regards,

-Roberto

[0] http://bugs.debian.org/610977

-- 
Roberto C. Sánchez
http://people.connexer.com/~roberto
http://www.connexer.com

Attachment: signature.asc
Description: Digital signature


Reply to: