[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

postgresql-8.4 and lenny upgrades (was Re: Bug#603141: dbi-link: fails to install due to incorrect dependencies in init.d LSB header)

found 603141 8.4.4-1+b1
fixed 603141 8.4.4-2

Hi there!

On Thu, 11 Nov 2010 10:31:00 +0100, Holger Levsen wrote:
> during a test with piuparts I noticed your package failed to install due to 
> incorrect dependencies in the init.d LSB header. Some debian notes are 
> available from at http://wiki.debian.org/LSBInitScripts
> From the attached log (scroll to the bottom...):
>   Setting up postgresql-8.4 (8.4.4-1+b1) ...
I could not find this version anymore, not in the postgresql-8.4's
debian/changelog nor in snapshots.d.o, where did it come from?

Please also note that at the time you sent the email, it seems that
squeeze already has 8.4.4-2:


>   insserv: script postgresql-8.4: service postgresql already provided!
>   insserv: exiting now!
>   update-rc.d: error: insserv rejected the script header

This was already reported (#585890, hey, by you!), solved in 8.4.4-2 (I
added the versions to the BTS):

--8<---------------cut here---------------start------------->8---
postgresql-8.4 (8.4.4-2) unstable; urgency=low

  * Migrate to a common init script for all server versions, to avoid
    providing the "postgresql" service in multiple packages (which causes
    insserv to complain bitterly):
    - Drop debian/postgresql-8.4.init.
    - debian/control: Bump dependency to postgresql-common to ensure we have a
      common /etc/init.d/postgresql init script.
    - debian/postgresql-8.4.preinst: Remove/rename our init script on upgrade.	
    - debian/postgresql-8.4.prerm: Call stop_version on upgrade.
    - debian/rules: Drop dh_installinit arguments.
    - (Closes: #585890)
--8<---------------cut here---------------end--------------->8---

> Please keep in mind that this was a test where first the lenny version was 
> installed and then an upgraded was done to squeeze. Also this bug is probably 
> just another duplicate of #603140, if so, please reassign there. (And sorry 
> for the noise.)

And yes, I would also say this was a duplicate of #603140, fixed in

On Wed, 24 Nov 2010 18:30:26 +0100, Holger Levsen wrote:
> On Mittwoch, 24. November 2010, Alexander Reichle-Schmehl wrote:
>> notfound 603141 2.0.0-3
> [...]
>> I'm quite sure that this is a failse positive, and therefore mark this
>> bug as done.
> A false-positive for dbi-link probably, but its a real bug when upgrading from 
> lenny.

I tried to reproduce your upgrade bug, but with no success, both in
piuparts or in a cowbuilder lenny chroot:
(lenny)root@gismo:/# apt-get install dbi-link
(lenny)root@gismo:/# sed -i -e 's/lenny/squeeze/g' /etc/apt/sources.list
(lenny)root@gismo:/# apt-get update && apt-get dist-upgrade
Setting up libyaml-perl (0.71-1) ...
Setting up dbi-link (2.0.0-3) ...
(lenny)root@gismo:/# dpkg -l postgresql\*
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                      Version                   
un  postgresql                <none>
un  postgresql-7.4            <none>
un  postgresql-8.0            <none>
ii  postgresql-8.3            8.3.12-0lenny1
ii  postgresql-8.4            8.4.5-0squeeze1
un  postgresql-client         <none>
ii  postgresql-client-8.3     8.3.12-0lenny1
ii  postgresql-client-8.4     8.4.5-0squeeze1
ii  postgresql-client-common  112
ii  postgresql-common         112
un  postgresql-doc-8.3        <none>
un  postgresql-doc-8.4        <none>
ii  postgresql-plperl-8.3     8.3.12-0lenny1
ii  postgresql-plperl-8.4     8.4.5-0squeeze1

However, I would like to note that an upgrade from lenny+backports to
squeeze is not possible, given that the version lenny-backports is
higher that the one in squeeze:
(lenny)root@gismo:/# echo \
 "deb http://backports.debian.org/debian-backports lenny-backports main" \
(lenny)root@gismo:/# apt-get update
(lenny)root@gismo:/# apt-get -t lenny-backports install postgresql-8.4
(lenny)root@gismo:/# sed -i -e 's/lenny/squeeze/g' /etc/apt/sources.list
(lenny)root@gismo:/# apt-get update
(lenny)root@gismo:/# apt-cache policy postgresql-8.4
(lenny)root@gismo:/# apt-cache policy postgresql-8.4
  Installed: 8.4.5-2~bpo50+1
  Candidate: 8.4.5-2~bpo50+1
  Version table:
 *** 8.4.5-2~bpo50+1 0
          1 http://backports.debian.org lenny-backports/main Packages
        100 /var/lib/dpkg/status
     8.4.5-0squeeze1 0
        500 http://cdn.debian.net squeeze/main Packages

So, for the current title of this bug everything is OK, while for the
upgrade from lenny+backports this is not, I will leave it to the
postgresql-8.4 maintainers ;-)

Thx, bye,
Gismo / Luca

Attachment: signature.asc
Description: Digital signature

Reply to: