[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#599751: unblock: nvidia-graphics-modules/195.36.31+2

Package: release.debian.org
Severity: normal
User: release.debian.org@packages.debian.org
Usertags: unblock

After discussion with the kernel team, we found that we should not be
releasing pre-built kernel modules for the Xen and OpenVZ flavors with
squeeze.  Apparently the ABI for these kernel flavors is not stable and
may change without changes to the ABI version.

This new version drops those packages and also fixes a place in the
build rules where it was depending on files in /usr/share/doc (to
determine the version number of nvidia-kernel-source), replacing it
with something more robust.  It also drops explicitly setting the
kernel version in favor of letting the package pick that up from the
kernel headers, which is a bit more robust in the face of weird things

Could you unblock this package?  Changelog is below.

unblock nvidia-graphics-modules/195.36.31+2

  [ Andreas Beckmann ]
  * debian/rules{,.defs}: Simplify disabling kernel flavors.
  * debian/rules: Use dpkg-query instead of manually parsing package versions
    from changelogs.
  * debian/rules: Stop passing KVERS to the module build.  The module
    build system will derive this information from the kernel headers.
  * Add myself to Uploaders.

  [ Russ Allbery ]
  * Drop Xen and OpenVZ kernel module flavors after discussion with the
    kernel team.  The ABIs for these kernels are not stable; there's no
    guarantee that prebuilt modules will continue working after kernel
    upgrades even if the ABI number doesn't change.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686-bigmem (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: