[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Pre-approval for nvidia-graphics-drivers 195.36.31-5

Hello release team,

Further upgrade testing by Andreas uncovered a few issues with
dependencies in the nvidia-graphics-drivers packages that I think are
appropriate to fix for squeeze since they could lead to upgrade problems
(particularly with partial upgrades).  Below is the changelog.  Is it okay
for me to upload a new version of this package to unstable?

The previous version has not yet propagated to testing due to ia32-libs,
which from other discussion I think is going to need another upload of
ia32-libs to resolve, so I don't believe this would delay propagation.

nvidia-graphics-drivers (195.36.31-5) UNRELEASED; urgency=low

  [ Andreas Beckmann ]
  * Drop Breaks: xserver-xorg-core (<< 2:1.6).
    There is no file name conflict between /usr/lib/libGLcore.so.1 (from
    NVIDIA) and /usr/lib/xorg/modules/extensions/libGLcore.so (only in
    xserver-xorg-core << 2:1.6) that could cause the wrong library to be
    loaded by NVIDIA's libgl.so.
  * Change xserver dependency to 'xorg-video-abi-6.0 | xserver-xorg-core
    (<< 2:1.7.7)' as the driver is supposed to work with older abi versions,
  * Add Pre-Depends: libc6-i386 (>= 2.9-18) to all packages handling files in
  * Restrict nvidia-opencl-common Recommends: nvidia-opencl-icd-ia32 to amd64.
  * libgl1-nvidia-alternatives needs to Breaks: old nvidia-glx*-dev packages,
    some were shipping a libGL.so symlink which may cause problems on partial
  * libgl*-nvidia-alternatives* needs to Depends: dpkg (>= 1.15) for using
    dpkg-divert --listpackage in the postinst script.

 -- Andreas Beckmann <debian@abeckmann.de>  Sun, 26 Sep 2010 08:08:02 +0200

Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>

Reply to: