[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Bug#592900: Updating system-config-printer

Hi Josselin,
On Sun, Sep 05, 2010 at 02:35:39PM +0200, Josselin Mouette wrote:
> Le vendredi 03 septembre 2010 à 13:18 +0200, Guido Günther a écrit :
> > > > However, I think ubuntu introduced a dummy hal-cups-utils package that
> > > > depends on s-c-p-udev to ease the transition.
> > > > 
> > > So I went and asked the apt people.  The problem seems to be that
> > > because python-cupsutils has reverse dependencies its removal gets a bad
> > > score.  Would it be possible to keep python-cupsutils as a dummy
> > > transitional package depending on python-cupshelpers?
> Since python-cupshelpers doesn’t provide the same APIs as
> python-cupsutils (they are not in the same namespace), it would be very
> wrong to do so.
I agree.

> The reverse dependencies need to be updated.
The problem here is that nothing else on the system uses
python-cupsutils.  It's s-c-p itself that gets a bad score during
dist-upgrade because python-cupsutils needs to be replace by
python-cupshelpers. Aptitude figures this out correctly but apt doesn't
and that's what bothers the release team.

I see two solutions:

* add the empty python-cupsutils package (which is a bad thing since
  other packages depending on python-cupsutils have their dependencies
  fulfilled but break).
* don't bother that apt doesn't get it right - i tried several other
  combinations but without a transitional package it didn't work out.

> > Josselin, would you agree? We had these in an early version and removed
> > them on your request. 
> > 
> > http://git.debian.org/?p=users/agx/system-config-printer.git;a=commit;h=c395d899b6f8ebb5e3bce298e2faa2d60f762231
> > 
> > I can add them back for hal-cups-utils as well as python-cupsutils.
> As for hal-cups-utils, I’ve uploaded the fixed meta-gnome2, which has
> been sitting in the SVN all the while.
 -- Guido

Reply to: