[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Please help a apt ABI break by providing bin-NMUs


On Wed, 2010-04-14 at 17:53 +0200, David Kalnischkies wrote:
> 2010/3/19 Michael Vogt <mvo@debian.org>:
> > bin-NMUs. The ABI break is required for following new features:
> > - allow multiple ddtp translation downloads
> > - allow Packages file without long descriptions [0]
> > - preparation of the cache/data structures for multi-arch support
> > - better logging
> Should we: open a bugreport,
> provide a list of whatever is needed,

Both of those would be good. :)

> I also want to emphasis that this is an ABI break - not an API
> break, so in an ideal world all rdepends just need to be rebuild.
> I tried this in the past weeks a few times with the bigger users²
> and so far everything builds and works as expected.
> ² libept, aptitude, python-apt, libapt-pkg-perl, debtags

I'm assuming the set of affected packages here are those build-depending
on libapt-pkg-dev or depending on libapt-pkg-libc6.9-6-4.8?



Reply to: