[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

live-magic 1.5+lenny1 for stable

Hi -release,

I didn't get the memo on the whole /etc/debian_version thing and would like
to upload live-magic 1.5+lenny1 to stable.

Live Magic parses this file in order to hide the selection of a distribution
to build, defaulting to allowing lenny if we are running lenny - we cannot
guarantee that squeeze or sid will always be bootstrappable from lenny's
{c,}debootstrap and we don't want to annoy users by it breaking.

The relevant changelog entry is:

  live-magic (1.5+lenny1) stable-proposed-updates; urgency=low

    * Don't assume /etc/debian_version will contain the string "5.0\n" for
      the entirety of the lenny release - just check for a prefix of "5.0".
     -- Chris Lamb <lamby@debian.org>  Tue, 05 May 2009 23:29:14 +0100

The entire diff is:

  --- a/LiveMagic/views/wizard.py
  +++ b/LiveMagic/views/wizard.py
  @@ -66,7 +66,7 @@ class WizardView(object):
           hide_distribution = False
               f = open('/etc/debian_version')
  -            if f.read(4) == "5.0\n":
  +            if f.read(3) == "5.0":
                   hide_distribution = True

This change has been uploaded to sid in live-magic 1.6.


     : :'  :     Chris Lamb
     `. `'`      lamby@debian.org

Attachment: signature.asc
Description: PGP signature

Reply to: