[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#524172: wrong depends on php5

Package: libphp-jpgraph
Version: 1.5.2-11+u1
Severity: grave

Hi Christian,

your package has wrong dependencies to php5. 

taken from debian/control:
| Depends: libapache2-mod-php5 | php4 | php4-cgi | libapache2-mod-php4, php5-gd | php4-gd

taken from http://www.aditus.nu/jpgraph/jpdownload.php
| PHP4: JpGraph 1.x - series
| Note: The 1.x series is only for PHP4. It will not work on PHP5.


| PHP5: JpGraph 2.x - series
| Note: The 2.x series is only for PHP5 (>= 5.1.x). It will not work on PHP4.

As we do not ship php4 with Lenny any more i suggest the removal of you package
from Lenny with the next point release (thus keeping debian-release@l.d.o on
CC), and updating to a newer version of your package for squeeze/sid.

I found that while debugging problems with limesurvey and stumbled over 


-- System Information:
Debian Release: 5.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-1-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Attachment: signature.asc
Description: Digital signature

Reply to: