[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#520441: RM: gtk+1.2 -- ROM; deprecated for 8 years, no security support

On Thu, Mar 19, 2009 at 10:55:31PM +0100, Frank Lichtenheld wrote:
> On Thu, Mar 19, 2009 at 09:00:26PM +0100, Josselin Mouette wrote:
> > Please remove gtk+1.2 from unstable. The last upstream release was 8 
> > years ago, and there isn???t any kind of maintenance happening on it, 
> > either upstream or in Debian.
> > 
> > This will immediately make all reverse dependencies uninstallable, but 
> > this is desirable. Those who can???t be updated will need to be removed as 
> > well. They have had plenty of time to switch to GTK+ 2.X now. We 
> > shouldn???t be struggling with GTK+ 1.2 while already planning the 
> > introduction of GTK+ 3. 
> Since AFAICT all of those packages already have RC bugs open against them,
> I would be open for the idea. But it might be preferable to remove the
> reverse-dependencies that are obsolete libraries themself earlier or
> at the same time, e.g. gnome-libs, wxwindows2.4, libgtkmm. 

We can remove the following right-away:
- gnome-libs
- wxwindows2.4
- gtkglarea
- gtkmm

imlib and gtk1.2 should be given some more time, they're much more smoothly
to remove once KDE 4 is uploaded to unstable.


Reply to: