[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Freeze exception for VDR 1.6.0-8



Hello!

Someone reported two bugs for VDR 1.6.0-7 in Lenny with severity
important. VDR is of priority extra, so this generally qualifies for a
freeze exception.

There is already a VDR 1.6.0-8 in Sid, which fixes those bugs. Please
check if this can be considered for a freeze exception. If not, please let
me know what changes are unacceptable and I will prepare a t-p-u.

Here's the changelog with some comments:

vdr (1.6.0-8) unstable; urgency=low

  * Added 18_vdr-maintenance-1.6.0-2.dpatch (Closes: #485593)

[comment] This is a maintenance patch published by the upstream author. It
fixes #510575 [2], which was tagged as important. The changelog of this
patch is:

- Updated the Italian OSD texts (thanks to Diego Pierotto).
- The SVDRP signon message now indicates the character encoding in use, as
  in "220 video SVDRP VideoDiskRecorder 1.7.1; Fri May  2 16:17:10 2008;
  ISO-8859-1". This may be useful for instance for external tools that
  provide EPG
  data, so that
  they can correctly encode the strings.
- No longer calling FcFini() to avoid problems with older (broken)
  versions of
  fontconfig (suggested by Edgar Toernig).
- Updated the sources.conf file (thanks to Oleg Roitburd).
- Fixed a possible integer overflow in GetAbsTime() (thanks to Alexander
  Rieger).
- Fixed a problem with calling isyslog() from within the SignalHandler()
  (thanks to Udo Richter).
- Replaced the Finnish language code "smi" with "suo" (thanks to Rolf
  Ahrenberg).
- Fixed wrong value for TableIdBAT in libsi/si.h (thanks to Winfried
  Köhler).
- Removed unneeded include files <linux/dvb/dmx.h> und <time.h> from
  remux.h

This patch fixes more than just the bugs filed against the Debian VDR
package, but it contains only minor tweaks to issues, which very well
could have been reported as important bugs to Debian. 1.6.0-8 has already
been tested by a large audience through Debian Sid and my private public
repository [2]. It would really be nice to see this upstream maintenance
patch in Lenny.

  * Added opt-21_internal-cam-devices.dpatch
  * Added opt-53_dvbsetup.dpatch
  * Added opt-54_deltimeshiftrec.dpatch

[comment] These dpatches are optional and are not used by the Debian VDR
package at all. They are just there to allow to easily compile a
customized version from the source package.

  * Replaced libcap-dev build dependency by libcap2-dev | libcap-dev
    (Closes: #492681)

  * Fixed detection of default LANG setting to be used for VDR

[comment] This fixes the important bug #510578 [3]

  * Updated README.Debian (Closes: #499047)
  * Fixed reference to /usr/share/doc/vdr/README.Debian.gz in
    /etc/default/vdr
  * Added missing dpatch descriptions
  * Removed Lintian override "shell-script-fails-syntax-check" for
    ./usr/share/vdr-dev/plugin-template/rules

 -- Tobias Grimm <etobi@debian.org>  Sat, 29 Nov 2008 14:21:04 +0100

Thanks a million,

Tobias

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=510575
[2] http://www.e-tobi.net/blog/pages/vdr-repository
[3] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=510578

Attachment: signature.asc
Description: OpenPGP digital signature


Reply to: