[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: remove libphp-phplot and acidlab from lenny

On Tue, Sep 16, 2008 at 05:04:04PM +0200, Thomas Viehmann wrote:
> Hi,
> as documented by #435176 and then #495083 libphp-phplot has been
> unusable since May 2007. In fact, it has been empty(!) since May 2008,
> i.e. for over four months, with no-one actually noticing until a bug
> report was filed in mid-August (unanswered for a month) - welcome to the
> wonderful world of diligent maintainer testing before upload.
> It has one reverse dependency, acidlab. No-one seems to have cared about
> acidlab being uninstallable or with unusable dependency for a year either.
> acidlab had previously been removed from unstable for neglect and
> libphp-phplot also had managed to raise QA concerns (#475757) which the
> maintainer violently. IMO it might be time to think about removal from
> unstable as well, but I'll leave that up to the QA people.

Acidlab does not actually require libphp-phplot. Many users can use acidlab
without the plotting functionality.

On the other hand Acidlab has ben superseded by acidbase. Which is an
enhanced fork that is being actively maintained (acidlab has not seen an
upstream update for years and will probably not see one anymore).

Acidlab use [1] has been diminishing in time whileas acidbase [2] has
increased so it is probably time to remove one in favour of the other one.

I cannot prepare a transition plan from one to the other (which should be more
than just an empty package with a Depends: acidbase). If somebody is willing
to help the existing Acidlab users with a transition package for lenny I would really
appreciate it.

If QA thinks that the best route is to RM this package that is fine too.



[1] http://qa.debian.org/popcon.php?package=acidlab
[2] http://qa.debian.org/popcon.php?package=acidbase

Attachment: signature.asc
Description: Digital signature

Reply to: