[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Yaird-devel] Bug#496500: yaird: fails to create initrd when running 2.6.24 etchnhalf kernel

Hash: SHA1

On Mon, Aug 25, 2008 at 04:29:39PM +0800, James Andrewartha wrote:
>Package: yaird
>Version: 0.0.12-18
>Severity: important
>This is bug 431534, exposed again because stable has an old version of
>yaird but a recent kernel.


I see some different approaches to this:

  1. Leave this bug open but do nothing about it.
     * This bug is not a security issue in itself
     * Security-related kernel updates can switch to initramfs-tools
  2. Release 0.0.12-18+etch1 fixing only this specific issue
     * Security-updates must be minimal
  3. Release backport of newest yaird in unstable
     * Linux changes are large already, so "must be minimal" cannot
       apply here
     * Most if not all recent yaird changes are to support the major 
       changes to recent Linux kernels
  4. Drop yaird from etchnhalf
     * Yaird has been dropped from testing (see bug#457177)

If we do 1) when should probably go through and etch-tag all other bugs 
fixed recently.

If we do 3) then a single change must be made compared to current 
package in Sid: LVM workaround must be enabled by default.

Cc'ing release team and security team for input.

NB! Even if yaird really is "generally too buggy" as judged in 
bug#457177, the current release in unstable is far better than the 
version currently in Etch, (contains no known regressions, and actually 
works out-of-the-box in many cases with recent Linux kernels whereas 
etch release don't).

  - Jonas

- -- 
* Jonas Smedegaard - idealist og Internet-arkitekt
* Tlf.: +45 40843136  Website: http://dr.jones.dk/

  [x] quote me freely  [ ] ask before reusing  [ ] keep private
Version: GnuPG v1.4.9 (GNU/Linux)


Reply to: