[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

freeze exceptions - making {java-gcj-compat,openjdk-6-jre}-headless installable without the complete jre packages

currently the -headless packages are not installable without having
the complete -jre packages installed on the system. the reason for
this is a dependency on the complete -jre packages in packages which
are dependencies of the -headless packages. The fix is to include an
alternative dependency on the -headless default-jre package. This

 libmx4j-java 3.0.2-4
 libregexp-java 1.4-5
 jakarta-log4j 1.2.15-4

java-package was extended to provide the "-headless"variants of the
java-runtime packages as well. this is done in 

 java-package 0.42

please consider a freeze exception for these packages.


Reply to: