[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Freeze exception for libapache2-mod-perl2/2.0.4-2

On Mon, Aug 11, 2008 at 01:31:33PM +0300, Damyan Ivanov wrote:
> [please cc debian-perl@lists.debian.org on replies]
> Dear release managers,
> Please allow the just-uploaded version 2.0.4-2 of libapache2-mod-perl2 
> to migrate to lenny. The upload contains a fix for a FTBFS bug[0] that 
> shows itself preferably on slow architectures.
> libcgi-pm-perl (which is added to build-dependencies) is at version 3.38 
> in lenny.

Darn, it failed on all autobuilders because their sbuilds still suffer
from #395271: they think that because perl-modules 
 Provides: libcgi-pm-perl
the versioned build-dependency is satisfied:
 libcgi-pm-perl: already installed (=*=PROVIDED=*= >= 3.33 is satisfied)
but dpkg-checkbuilddeps (correctly) disagrees:
 dpkg-checkbuilddeps: Unmet build dependencies: libcgi-pm-perl (>= 3.33)

(Note that the fix from #395271 leads to a problem with build-conflicts,
 see #483338, so I suppose it's not quite ready for prime time on the

I suppose we need to do something else to fix libapache2-mod-perl2.
Niko Tyni   ntyni@debian.org

Reply to: