[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#493938: ca-certificates needs mktemp without depending on it.

On Wed, Aug 06, 2008 at 11:58:48PM -0300, Philipp Kern wrote:
> To explain the situation:  mktemp is essential since 2006-05-18, which
> is the version in Etch.  ca-certificates does, of course, not depend on
> it, although it needs it in postinst.  This is already the second bug
> report I got about this issue, so it seems not that uncommon.
> The problem:  Machines upgraded from Sarge to Etch won't get mktemp
> pulled in, because nothing depends on essential packages.  They won't

FWIW, etch's debianutils depends on mktemp, and debianutils was
essential in sarge too.

Hamish Moffatt VK3SB <hamish@debian.org> <hamish@cloud.net.au>

Reply to: