[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Buildd policy WRT non-free build dependencies?

On Sat, May 24, 2008 at 11:37:55PM +0100, Thiemo Seufer wrote:
> These four packages currently fail to build on mips (and others):
> -- contrib packages which b-d on non-free packages --
> motv            # needs libmotif-dev, orphaned, #379256
> suitesparse-metis # needs libparmetis-dev, RC bug #478179
> octave-gpc      # needs libgpcl-dev
> sivp            # needs scilab-bin

I also have snes9express_1.42-7 on amd64 that Build-Depends on

The problem is that I have no idea which license I'm going to agree with
when installing/using something from non-free.

I would prefer a solution like the one for building non-free packages
and that there would be a list that gets approved for which packages
might be safe to install and build something with.


Reply to: