[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bugs that'll block python 2.5

On Mon, 14 Apr 2008, Adeodato Simó wrote:
> Finally, and quite importantly, there is what to do with modules that
> have been added to the standard library in 2.5 (ctypes, celementtree,
> wgsiref). These use either pycentral or pysupport, and since they mark
> themselves as for python << 2.5 only, the dependency generated is on
> python (<< 2.5), rendering them uninstallable.

I think they should simply be updated to not use ${python:Depends}.
I wonder if that should be replaced by some custom dependency however.
Probably not. There's no reason to depend on python-2.4... that's the
job of packages containing python scripts requiring 2.4.

Raphaël Hertzog

Le best-seller français mis à jour pour Debian Etch :

Reply to: