[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [pkg-boost-devel] Bug#454605: Boost & gcc 4.1 (was Bug#454605: build against new icu 3.8 packages)

On Sun, Dec 09, 2007 at 07:44:05AM -0600, Steve M. Robbins wrote:
> On Thu, Dec 06, 2007 at 05:55:29PM +0100, Domenico Andreoli wrote:

> >   rebuilding Boost as-is would require a new Boost transition. Could
> > we continue to build it with gcc 4.1? At least until 1.35.0 is out,
> > that could be a few months away.

> On the other hand, gcc default is version 4.2 since September 1.  It
> would be nice to have boost built with the default gcc.

> Couldn't we do the transition now?

It took four months to complete the last boost transition.  I don't think
we need another one of those (ever).

Please fix the boost package to *not* encode the compiler version in the
library names.  (I.e., please maintain compatibility with the binaries
currently in the archive.)

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                    http://www.debian.org/
slangasek@ubuntu.com                                     vorlon@debian.org

Reply to: