[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Report on the situation of python2.5 in Debian

Josselin Mouette wrote:
> Le samedi 06 octobre 2007 à 09:07 +0200, Josselin Mouette a écrit :
>> Le vendredi 05 octobre 2007 à 20:04 +0200, Josselin Mouette a écrit :
>>> The following packages should also work with python2.5 after a round of
>>> binNMUs, as some dependencies were relaxed in python-support 0.7.4:
>>>         dia
>>>         exaile
>>>         k3d
>> You can add:
>> 	mod-wsgi
>> which in fact enters in this category.
> Or not. These dependencies are explicitly added by debian/rules for no
> reason.

Sorry , but there is a very good reason to do so: If the default python
version changes running applications with mod-wsgi will badly fail.
Therefore it depends in a relaxed way (python <<2.5, but >=2.4) on the
actual default python version which was used to build the package. If
you rebuild it with python2.5 as default python version, it'll just add
the right dependencies. This was tested on Ubuntu and works well. It's
nothing but an extra safety to stop people from upgrading python or
mod-wsgi, they need to be upgraded both.

Bernd Zeimetz
<bernd@bzed.de>                         <http://bzed.de/>

Reply to: