[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: svn-buildpackage - broken in etch

On Wed, Jan 24, 2007 at 12:09:16AM +0000, Ben Hutchings wrote:
> On Tue, 2007-01-23 at 23:07 +0100, Luk Claes wrote:
> > Luk Claes wrote:
> > > Ben Hutchings wrote:
> > >> I just ran into bug #398185, which makes the svn-upgrade program in
> > >> svn-buildpackage unusable.  It is not marked as RC but it seems to me
> > >> that it might as well be.  It was fixed in unstable after the freeze
> > >> (along with many other bugs).  Please consider allowing the newer
> > >> version into etch.

> > > Unblocked.

> > I was sending this one too fast... not unblocked as too many code changes
> > which don't qualify for release exception, sorry.

> I wonder whether it would be possible to apply just the svn_load_dirs
> fix via t-p-u?

Personally, I'm not sure this is warranted; svn-upgrade is an optional
feature of svn-buildpackage, which I don't think is used by terribly many
maintainers.  And indeed, the changes related to svn_load_dirs alone are
fairly intrusive and arguably not suitable for a t-p-u upload.

If the maintainer wants to upload a targetted fix to t-p-u, I suppose we can
consider it, but it doesn't really seem all that severe of an issue to me
(speaking as an svn-buildpackage user).

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Reply to: