[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

please hint flpsed 0.3.7-1.1


the version 0.3.7-1 of flpsed in Etch is in bad shape; it is almost
unusable, due to these issues:

- it needs a "gs" as a backend, but there is no Depends
 (see bug 402451)
- it does not work with gs-gpl, but only with "gs-esp"
 (see again bug 402451)

IMHO the above render the package not really fit for Etch - I also
tested that bug on two different hosts, and it always shows;

I posted this bug 1month ago, but apparently the mantainer is MIA (also,
the mantainer is not a DD);

So I decided to address those problems.

There is a new upstream version 0.3.9; the best thing would have been
to upload 0.3.9  ; but, in the "freeze" spirit, I tried to keep changes
at a minimum; so I studied the diff 0.3.7 -> 0.3.9 and tried to do my
best. Doing that, I also decided to solve some other problems and bugs
in this NMU.

Here are the bugs solved by this NMU

-------- code related issues

--- bug 402451 : flpsed does not work with gs-gpl
The upstream author chose to add a XSync() ; I tried that , and it does
not work here; so I resolved to call "gs-esp" directly

--- bug 398906 :  uses an unknown font 'HelveticaNeue-Roman'.
 I changed that to Helvetica (as is done in 0.3.9)

-------- packaging related bugs

--- (no bug)
debian/rules : use "make distclean"  instead of "make clean" ;
this deletes a lot of auto* cruft , that was (erroneously)
 shipped inside  flpsed....diff.gz , and was generating lintian warnings

--- bug 388318   "pdftops needed for pdf import"
Add Recommends: xpdf-utils | poppler-utils

--- bug 402451 again
add Depends: gs-esp


The complete diff of my NMU is in


(but I deleted from that all interdiffs that were complaining because a
lot of auto* generated files have disappeared :-)


please let this new flpsed into Etch


Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: